tutorials questions & answers
by

Metatrader 4 on startup goes wrong

TAGS:
  • metatrader
  • Windows 2012 r2

Hello, I have a problem when I'm putting Metatrader 4 in the Task Scheudler. It opens up Metatrader on startup, but it is getting opened like I have just installed it. When I'm logging on via RDP and start the program manually, I have no problems and everything is set up with my Expert Advisors and so on. Does somebody know how to fix this problem? I'm also using autologon, so that Metatrader can start without typing the Password.

comments (1)

  •  2 6 3 3 7 7 ☺ 

    reply 0 3 months ago

    Greetings,

    I haven't used that program specifically, but have had similar issues in the past and think I may have a suggestion worth looking into;

    Most likely it is started with an other user/permissions than the one you are used to and commonly log on to use it with, and thus the program creates a separate registry- or file- record with configuration data upon its first launch as if its a new user.

    Likely it's some username appearing as "SYSTEM" or such, I'd think.

    If you are in Windows Task Scheduler, either search "schedul " .. (it should fill in the rest and find it, if Search Indexer is running) or search / run "Taskschd.msc" (in windows\system32 dir. if can't find otherwise) -- open task scheduler, mark and highlight your program / process, then right click and Properties.

    Top tab 'General' -> 'Security Options' > ("When running the task, use the following user account:") 'Change User or Group'.

    I presume "SYSTEM" is currently listed as the user it is to run as. If so try 'Change User or Group...', and you will have a text-box you can type into. Enter the username of the account you usually run it under.

    I don't know why you are using scheduler and how it's set up to start, with what privileges and eventually what form it eventually runs as, but there are many other better options I believe.

    Is this a program you need running constantly 24/7? If not, maybe simply add it to normal Windows start-up group, or even to run alongside your user. Only when, and every time your user logs in. You may find the "Local users and groups"-manager by running lusrmgr.msc
    Click the Users-folder and highlight/mark your username, then right-click and properties. There is a tab named 'Environment' where you can mark 'Start the following program at login:'-checkbox.

    First, are you sure you don't simply have multiple Remote Desktop users running concurrently? If to ensure running as the Administrator- or an other user each time, you can start Remote Desktop by typing mstsc /v:123.123.123.123 /f where 123.123.123.123 is the server's IP. If all sessions are occupied this would also force out any others (log them out) given you have administrative rights.

    While in the Properties page for your user, may want to look over the 'Sessions'-tab as well. There you can choose whether to terminate each session by closing down as in logging off, terminating or putting applications idle, or if maintain a disconnected session.

    There are numerous other ways you could auto-start it, but I think a non-background task, runas:YourUser type of setup will be best for your use..

    Microsoft has a set of tools that helps with finding, changing properties and assisting with tasks like autostarting programs, it's named 'SysInternals' can can be downloaded (freely) as a bundle or each program seperately from https://technet.microsoft.com/en-us/sysinternals/ .

    If you really want know how, under what user, eventual issues or such following auto-start of a program at logon you could also see windows event logs. You can open it by running eventvwr.msc Left side 'Windows Logs' > 'Application' > Press the F3-button to search; input your application name.

    Sorry this was a lot of text.. and for something likely very easy to fix, and which has numerous ways for getting sorted.. Hopefully I managed to explain what you needed in a way that was understandable, and that you get it working.

    May be some others get some tips from this as well! (anyone feel like rewriting with better english and minor corrections then please do. This is my first post here btw., I do not need any in return/compensation.:)

    If still problems, please try elaborate further to more easily help narrow down what needs changing :-)

    Good luck ! ☺

    & g'day n take care.. ^_-

    Best rgds,  2 6 3 3 7 7 

leave comment

Please choose login or register to comment in this thread.

Start now for as low as $5 a month!

  • 8 Characters
  • 1 Uppercase Atleast
  • 1 Number Atleast